re = /^(?!.*square).*front/m
str = 'foo bar front
abc pqr
foo bar front square
foo bar square front
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end