using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=เลขที่ : )[\d-.,]+";
string input = @" PHAYATHAI BANGKOK เลขที่ : 21193-01-06177
จํานวนเงินรวม 1,118,753.77 15,741.94 1,101.92 1,101,909.91
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}