re = /(?<=เลขที่ : )[\d-.,]+/m
str = ' PHAYATHAI BANGKOK เลขที่ : 21193-01-06177
จํานวนเงินรวม 1,118,753.77 15,741.94 1,101.92 1,101,909.91
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end