using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Abholstellenname\s\(Firmenname,\sDetails\):\s).*[^<br>]+";
string input = @"Abholstellenname (Firmenname, Details): Musterfirma GmbH<br>
Abholstellenname (Firmenname, Details): Musterfirma GmbH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}