$re = '/(?<=Abholstellenname\s\(Firmenname,\sDetails\):\s).*[^<br>]+/m';
$str = 'Abholstellenname (Firmenname, Details): Musterfirma GmbH<br>
Abholstellenname (Firmenname, Details): Musterfirma GmbH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);