import re
regex = re.compile(r"^\s*\x60(\w*)\x60\s*(.*?)(?:COMMENT \'(.*)\')?,$", flags=re.MULTILINE)
test_str = (" `wallet_number` varchar(15) NOT NULL,\n"
" `created_by` bigint(20) DEFAULT NULL,\n"
" `updated_by` bigint(20) DEFAULT NULL,\n"
" `deleted_by` bigint(20) DEFAULT NULL COMMENT 'Due date of task',\n"
" `status` int(11) NOT NULL,\n"
" `comment` longtext,\n"
" `createdAt` datetime DEFAULT NULL,\n"
" `updatedAt` datetime DEFAULT NULL,\n"
" PRIMARY KEY (`wallet_number`)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")