using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[0-9])(?=.*[A-Z])([A-Z0-9]+)";
string input = @"HELLO 1 WORLD!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}