$re = '/(?=.*[0-9])(?=.*[A-Z])([A-Z0-9]+)/';
$str = 'HELLO 1 WORLD!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);