# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]{2}\/[0-9]{2}\/[0-9]{4}"
test_str = ("Valid dates:\n\n"
"01/04/2020\n"
"20/01/2019\n"
"25/12/1950\n"
"30/07/2021\n"
"31/08/1919\n"
"01/01/1729\n"
"10/05/2000\n"
"15/10/2049\n\n"
"Invalid dates:\n\n"
"001/04/1900\n"
"01/004/1900\n"
"90/04/1900\n"
"33/04/1900\n"
"01/13/1900\n"
"01/04/19000\n"
"00/04/1900\n"
"01/00/1900\n"
"1/4/00\n"
"1/04/1900\n"
"10/4/1900\n"
"10/04/00\n"
"///\n"
"/04/1900\n"
"01//1900\n"
"01/04/\n"
"01/04/1900\n"
"This is the date: 01/04/1900\n"
"01.04.1900\n"
"01-04-1900\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.