#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<div[^>]*?>(?:(?-1)|(?!<\/?div).)*<\/div>)"
Local $sString = "<div class="portlet-body author-note"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>" & @CRLF & _
"<div class="spoiler"></div>" & @CRLF & _
"<div class="smalltext"><strong>Spoiler</strong> : <input class="spoilerButton"/></div>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div class="outer">" & @CRLF & _
"<div class="spoiler">" & @CRLF & _
"some stuff" & @CRLF & _
"some more stuff" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
" <p>R Quam<br/>" & @CRLF & _
" Rory<br/>" & @CRLF & _
" PiMs<br/>" & @CRLF & _
" Imi256<br/>" & @CRLF & _
" Thomas Belvin<br/>" & @CRLF & _
" Jacob<br/>" & @CRLF & _
"<div class "just for fun"></div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<p> </p><div>h<div>e<div>l<div>l<div>o</div></div></div></div></div>" & @CRLF & _
"<p>We are currently reaching 3 weeks </p>" & @CRLF & _
"</div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")