$re = '/(<div[^>]*?>(?:(?-1)|(?!<\/?div).)*<\/div>)/s';
$str = '<div class="portlet-body author-note"><p>Thanks to the massive new influx of patrons! You guys rock! (and stone!)</p>
<div class="spoiler"></div>
<div class="smalltext"><strong>Spoiler</strong> : <input class="spoilerButton"/></div>
</div>
<div class="outer">
<div class="spoiler">
some stuff
some more stuff
</div>
<p>R Quam<br/>
Rory<br/>
PiMs<br/>
Imi256<br/>
Thomas Belvin<br/>
Jacob<br/>
<div class "just for fun"></div>
</div>
<p> </p><div>h<div>e<div>l<div>l<div>o</div></div></div></div></div>
<p>We are currently reaching 3 weeks </p>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);