using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*c\K|(?!^)aa";
string input = @"aabaabaabbaab (no little C's)
aabaacbaabbaa (one little C)
aabcaabcbaabaa (two little C's)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}