$re = '/^.*c\K|(?!^)aa/m';
$str = 'aabaabaabbaab (no little C\'s)
aabaacbaabbaa (one little C)
aabcaabcbaabaa (two little C\'s)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);