#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*SHELF)-(.*)\[.*SHELF-(.*)\]"
Local $sString = "PSHELF-2[PSHELF-MF-6RU]" & @CRLF & _
"SHELF-5[SHELF-M6]" & @CRLF & _
"SHELF-6[SHELF-M15]" & @CRLF & _
"" & @CRLF & _
"SHELF-6[SHELF-M15]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")