package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*SHELF)-(.*)\[.*SHELF-(.*)\]`)
var str = `PSHELF-2[PSHELF-MF-6RU]
SHELF-5[SHELF-M6]
SHELF-6[SHELF-M15]
SHELF-6[SHELF-M15]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}