$re = '/(\((?>[^()\\\\]++|\\\\.|(?1))*+\))|\b(2)(?=\b(?:,|\(|\'|$))/m';
$str = '2(2\'Abf\',3),212,2\'abc\',2(1,2\'abd\',3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);