package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)sunlife|zurich`)
var str = `Paul.Walker@redsunlife.com test@testzurich.com
Paul.Walker@redSunlife.com
Paul.Walker@redSUNLIFE.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}