$re = '/sunlife|zurich/mi';
$str = 'Paul.Walker@redsunlife.com test@testzurich.com
Paul.Walker@redSunlife.com
Paul.Walker@redSUNLIFE.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);