package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[[:alnum:]]+`)
var str = `Q=m*c*[t2*result]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}