$re = '/[[:alnum:]]+/m';
$str = 'Q=m*c*[t2*result]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);