package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?\w+=\{\d+\}`)
var str = `?pid={10202}?pid2={10202}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}