$re = '/\?\w+=\{\d+\}/';
$str = '?pid={10202}?pid2={10202}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);