#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(\'DB_NAME\'\,\s\')([a-z]*)(\'\)\;)"
Local $sString = "<?php" & @CRLF & _
"define('WP_AUTO_UPDATE_CORE', false);// This setting was defined by WordPress Toolkit to prevent WordPress auto-updates. Do not change it to avoid conflicts with the WordPress Toolkit auto-updates feature." & @CRLF & _
"/**" & @CRLF & _
" * The base configuration for WordPress" & @CRLF & _
" *" & @CRLF & _
" * The wp-config.php creation script uses this file during the" & @CRLF & _
" * installation. You don't have to use the web site, you can" & @CRLF & _
" * copy this file to "wp-config.php" and fill in the values." & @CRLF & _
" *" & @CRLF & _
" * This file contains the following configurations:" & @CRLF & _
" *" & @CRLF & _
" * * MySQL settings" & @CRLF & _
" * * Secret keys" & @CRLF & _
" * * Database table prefix" & @CRLF & _
" * * ABSPATH" & @CRLF & _
" *" & @CRLF & _
" * @link https://codex.wordpress.org/Editing_wp-config.php" & @CRLF & _
" *" & @CRLF & _
" * @package WordPress" & @CRLF & _
" */" & @CRLF & _
" " & @CRLF & _
"// ** MySQL settings - You can get this info from your web host ** //" & @CRLF & _
"/** The name of the database for WordPress */" & @CRLF & _
"define('DB_NAME', '--------------');" & @CRLF & _
" " & @CRLF & _
"/** MySQL database username */" & @CRLF & _
"define('DB_USER', '--------------');" & @CRLF & _
" " & @CRLF & _
"/** MySQL database password */" & @CRLF & _
"define('DB_PASSWORD', '--------------');" & @CRLF & _
" " & @CRLF & _
"/** MySQL hostname */" & @CRLF & _
"define('DB_HOST', 'srv-pleskdb15.ps.kz:--------------');" & @CRLF & _
" " & @CRLF & _
"/** Database Charset to use in creating database tables. */" & @CRLF & _
"define('DB_CHARSET', 'utf8');" & @CRLF & _
" " & @CRLF & _
"/** The Database Collate type. Don't change this if in doubt. */" & @CRLF & _
"define('DB_COLLATE', '');" & @CRLF & _
" " & @CRLF & _
"/**#@+" & @CRLF & _
" * Authentication Unique Keys and Salts." & @CRLF & _
" *" & @CRLF & _
" * Change these to different unique phrases!" & @CRLF & _
" * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}" & @CRLF & _
" * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again." & @CRLF & _
" *" & @CRLF & _
" * @since 2.6.0" & @CRLF & _
" */" & @CRLF & _
"define('AUTH_KEY', '=======================================================');" & @CRLF & _
"define('SECURE_AUTH_KEY', '=======================================================');" & @CRLF & _
"define('LOGGED_IN_KEY', '=======================================================');" & @CRLF & _
"define('NONCE_KEY', '=======================================================');" & @CRLF & _
"define('AUTH_SALT', '=======================================================');" & @CRLF & _
"define('SECURE_AUTH_SALT', '=======================================================');" & @CRLF & _
"define('LOGGED_IN_SALT', '=======================================================');" & @CRLF & _
"define('NONCE_SALT', '=======================================================');" & @CRLF & _
"/**#@-*/" & @CRLF & _
" " & @CRLF & _
"/**" & @CRLF & _
" * WordPress Database Table prefix." & @CRLF & _
" *" & @CRLF & _
" * You can have multiple installations in one database if you give each" & @CRLF & _
" * a unique prefix. Only numbers, letters, and underscores please!" & @CRLF & _
" */" & @CRLF & _
"$table_prefix = 'q3j5sI_';" & @CRLF & _
" " & @CRLF & _
"/**" & @CRLF & _
" * For developers: WordPress debugging mode." & @CRLF & _
" *" & @CRLF & _
" * Change this to true to enable the display of notices during development." & @CRLF & _
" * It is strongly recommended that plugin and theme developers use WP_DEBUG" & @CRLF & _
" * in their development environments." & @CRLF & _
" *" & @CRLF & _
" * For information on other constants that can be used for debugging," & @CRLF & _
" * visit the Codex." & @CRLF & _
" *" & @CRLF & _
" * @link https://codex.wordpress.org/Debugging_in_WordPress" & @CRLF & _
" */" & @CRLF & _
"define('WP_DEBUG', false);" & @CRLF & _
" " & @CRLF & _
"/* That's all, stop editing! Happy blogging. */" & @CRLF & _
" " & @CRLF & _
"/** Absolute path to the WordPress directory. */" & @CRLF & _
"if ( !defined('ABSPATH') )" & @CRLF & _
" define('ABSPATH', dirname(__FILE__) . '/');" & @CRLF & _
" " & @CRLF & _
"/** Sets up WordPress vars and included files. */" & @CRLF & _
"require_once(ABSPATH . 'wp-settings.php');" & @CRLF & _
" " & @CRLF & _
"define( 'WP_ALLOW_MULTISITE', true );" & @CRLF & _
" " & @CRLF & _
"define ('FS_METHOD', 'direct');" & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")