# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\(\'DB_NAME\'\,\s\')([a-z]*)(\'\)\;)"
test_str = ("<?php\n"
"define('WP_AUTO_UPDATE_CORE', false);// This setting was defined by WordPress Toolkit to prevent WordPress auto-updates. Do not change it to avoid conflicts with the WordPress Toolkit auto-updates feature.\n"
"/**\n"
" * The base configuration for WordPress\n"
" *\n"
" * The wp-config.php creation script uses this file during the\n"
" * installation. You don't have to use the web site, you can\n"
" * copy this file to \"wp-config.php\" and fill in the values.\n"
" *\n"
" * This file contains the following configurations:\n"
" *\n"
" * * MySQL settings\n"
" * * Secret keys\n"
" * * Database table prefix\n"
" * * ABSPATH\n"
" *\n"
" * @link https://codex.wordpress.org/Editing_wp-config.php\n"
" *\n"
" * @package WordPress\n"
" */\n"
" \n"
"// ** MySQL settings - You can get this info from your web host ** //\n"
"/** The name of the database for WordPress */\n"
"define('DB_NAME', '--------------');\n"
" \n"
"/** MySQL database username */\n"
"define('DB_USER', '--------------');\n"
" \n"
"/** MySQL database password */\n"
"define('DB_PASSWORD', '--------------');\n"
" \n"
"/** MySQL hostname */\n"
"define('DB_HOST', 'srv-pleskdb15.ps.kz:--------------');\n"
" \n"
"/** Database Charset to use in creating database tables. */\n"
"define('DB_CHARSET', 'utf8');\n"
" \n"
"/** The Database Collate type. Don't change this if in doubt. */\n"
"define('DB_COLLATE', '');\n"
" \n"
"/**#@+\n"
" * Authentication Unique Keys and Salts.\n"
" *\n"
" * Change these to different unique phrases!\n"
" * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}\n"
" * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.\n"
" *\n"
" * @since 2.6.0\n"
" */\n"
"define('AUTH_KEY', '=======================================================');\n"
"define('SECURE_AUTH_KEY', '=======================================================');\n"
"define('LOGGED_IN_KEY', '=======================================================');\n"
"define('NONCE_KEY', '=======================================================');\n"
"define('AUTH_SALT', '=======================================================');\n"
"define('SECURE_AUTH_SALT', '=======================================================');\n"
"define('LOGGED_IN_SALT', '=======================================================');\n"
"define('NONCE_SALT', '=======================================================');\n"
"/**#@-*/\n"
" \n"
"/**\n"
" * WordPress Database Table prefix.\n"
" *\n"
" * You can have multiple installations in one database if you give each\n"
" * a unique prefix. Only numbers, letters, and underscores please!\n"
" */\n"
"$table_prefix = 'q3j5sI_';\n"
" \n"
"/**\n"
" * For developers: WordPress debugging mode.\n"
" *\n"
" * Change this to true to enable the display of notices during development.\n"
" * It is strongly recommended that plugin and theme developers use WP_DEBUG\n"
" * in their development environments.\n"
" *\n"
" * For information on other constants that can be used for debugging,\n"
" * visit the Codex.\n"
" *\n"
" * @link https://codex.wordpress.org/Debugging_in_WordPress\n"
" */\n"
"define('WP_DEBUG', false);\n"
" \n"
"/* That's all, stop editing! Happy blogging. */\n"
" \n"
"/** Absolute path to the WordPress directory. */\n"
"if ( !defined('ABSPATH') )\n"
" define('ABSPATH', dirname(__FILE__) . '/');\n"
" \n"
"/** Sets up WordPress vars and included files. */\n"
"require_once(ABSPATH . 'wp-settings.php');\n"
" \n"
"define( 'WP_ALLOW_MULTISITE', true );\n"
" \n"
"define ('FS_METHOD', 'direct');\n"
"?>")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.