$re = '/(`[a-zA-Z0-9_]+){2,}/m';
$str = 'hasdfk sdlkj 234 g `lkj `fred`joe`sally `fred
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);