re = /(`[a-zA-Z0-9_]+){2,}/m
str = 'hasdfk sdlkj 234 g `lkj `fred`joe`sally `fred
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end