re = /^[+-]?[0-9]+(?:,[0-9]+)*(?:\.[0-9]+)?$/m
str = '111
1.11
1,111
1,111.01
+111
+1.11
+1,111
+1,111.01
-111
-1.11
-1,111
-1,111.01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end