using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\-?\d*\-?\d+)\/(\d+$))|(^\-?\d+$)";
string input = @"/ in str
3/5
33/55
-3/5
-33/55
/ not in str
3
-3
33
-33
carry
1-1/2
-1-1/2
#invalid
/
-
3/
/33
3-3
1-/2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}