$re = '/(?<environment>\w+)\.(?<company>[a-zA-Z-_]+)\.(?<logtype>[a-zA-Z-_]+)/m';
$str = '/var/log/nginx/live.cnt-environmental.error.log
/var/log/nginx/staging.perl-mini.access.log
/var/log/nginx/dev.molder.error.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);