import Foundation
let pattern = #"(?<environment>\w+)\.(?<company>[a-zA-Z-_]+)\.(?<logtype>[a-zA-Z-_]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/var/log/nginx/live.cnt-environmental.error.log
/var/log/nginx/staging.perl-mini.access.log
/var/log/nginx/dev.molder.error.log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)