using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(address|notes)='\K(?:\\\'|[^'])*";
string input = @"address='St Marks Church',notes='The North East\'s premier...'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}