re = /(address|notes)='\K(?:\\\'|[^'])*/
str = 'address=\'St Marks Church\',notes=\'The North East\\\'s premier...\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end