using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[""[PM]\d{3,5}Z[pm]\d{3,5}(?:"",""[PM]\d{3,5}Z[pm]\d{3,5}){7}""]$";
string input = @"[""P4950Zp550"",""P4950Zp575"",""P4950Zp600"",""P5000Zp550"",""P5000Zp575"",""P5000Zp600"",""P4975Zp550"",""P4975Zp600""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}