import re
regex = re.compile(r"^\[\"[PM]\d{3,5}Z[pm]\d{3,5}(?:\",\"[PM]\d{3,5}Z[pm]\d{3,5}){7}\"]$")
test_str = "[\"P4950Zp550\",\"P4950Zp575\",\"P4950Zp600\",\"P5000Zp550\",\"P5000Zp575\",\"P5000Zp600\",\"P4975Zp550\",\"P4975Zp600\"]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")