re = /^(?=.*?(?<text>[A-Z].+))(?<value>.+)/m
str = 'elasticsearch_sync_queue_lowerlevelgiberishManualAllocationPolicy:pending
asdAsdfasdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end