$re = '/^[^%\n]*(?:%(?!3F)[^%\n]*)*/m';
$str = 'https%3A%2F%2Fwww.facebook.com%2F
https%3A%2F%2Fwww.facebook.com%2F%3Futm_source';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);