re = /^[^%\n]*(?:%(?!3F)[^%\n]*)*/m
str = 'https%3A%2F%2Fwww.facebook.com%2F
https%3A%2F%2Fwww.facebook.com%2F%3Futm_source'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end