package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\(\ ?)?
(
(?:(?:\**\[(?:!?\d+)?\])*\**[A-Za-z_]\w*)++
(?:\ ?\|\ ?(?:\**\[(?:!?\d+)?\])*\**[A-Za-z_]\w*)+
)
(?:\ ?\))?`)
var str = `something_happened (branch|leaf)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}