re = /(?:\(\ ?)?
(
(?:(?:\**\[(?:!?\d+)?\])*\**[A-Za-z_]\w*)++
(?:\ ?\|\ ?(?:\**\[(?:!?\d+)?\])*\**[A-Za-z_]\w*)+
)
(?:\ ?\))?/mx
str = 'something_happened (branch|leaf)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end