$re = '/^\d+(,\d{3})*$/m';
$str = '123,700
123
1
123,700,123,700';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);