import re
regex = re.compile(r"^(?<local>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~\"]+)(?:\.)?(?<routing>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~+\"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\-[\]]*)(?:\.)(?:[a-zA-Z0-9\-[\]\.]*))$", flags=re.MULTILINE)
test_str = ("yemolai+hello+amps@gmail.com\n"
"romulogabriel@outlook.com.br\n"
"a13b3440.junior@gmail.jp\n"
"gabriel.rodrigues@sedop.pa.gov.br\n"
"rubens.junior00k@hotmail-p.com\n"
"adam.mills@[192.168.1.1]\n"
"a@B.com\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")