// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?<local>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~"]+)(?:\.)?(?<routing>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~+"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\-[\]]*)(?:\.)(?:[a-zA-Z0-9\-[\]\.]*))$"#).unwrap();
let string = "yemolai+hello+amps@gmail.com
romulogabriel@outlook.com.br
a13b3440.junior@gmail.jp
gabriel.rodrigues@sedop.pa.gov.br
rubens.junior00k@hotmail-p.com
adam.mills@[192.168.1.1]
a@B.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}