$re = '/^(\+{1}|\+{3})(?!\+)( |.*?\bconsole.log\()/m';
$str = '+++ testserver.js
+console.log(djsdlkjd)
+// console.log(djsdlkjd)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);