re = /^(\+{1}|\+{3})(?!\+)( |.*?\bconsole.log\()/m
str = '+++ testserver.js
+console.log(djsdlkjd)
+//   console.log(djsdlkjd)'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end