using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Candidate name:\s*\K(?:(?<title>(?:Mr|Mrs|Dr|Rev)\.)\s*)?(?<name>(?:(?:[-\w']+)\s+)*)(?<family_name>[-\w']+)$";
string input = @"Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O'Donnell
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}