$re = '/Candidate name:\s*\K(?:(?<title>(?:Mr|Mrs|Dr|Rev)\.)\s*)?(?<name>(?:(?:[-\w\']+)\s+)*)(?<family_name>[-\w\']+)$/m';
$str = 'Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O\'Donnell
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);