#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^({"parameters": \[\n[[:space:]]+{\n[[:space:]]+"name": "dir_parm",\n[[:space:]]+"value": ")[^"]*("\n[[:space:]]+}\n[[:space:]]+\],\n[[:space:]]+"targets": \[\n[[:space:]]+{\n[[:space:]]+"identifier": ")[^"]*("\n[[:space:]]+}\n[[:space:]]+\]\n+[[:space:]]+})"
Local $sString = "{"parameters": [" & @CRLF & _
" {" & @CRLF & _
" "name": "dir_parm"," & @CRLF & _
" "value": "changethis"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "targets": [" & @CRLF & _
" {" & @CRLF & _
" "identifier": "hsotchangethis"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"" & @CRLF & _
"}"
Local $sSubst = "$1>>>>>$2>>>>>>>$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)