$re = '/^({"parameters": \[\n[[:space:]]+{\n[[:space:]]+"name": "dir_parm",\n[[:space:]]+"value": ")[^"]*("\n[[:space:]]+}\n[[:space:]]+\],\n[[:space:]]+"targets": \[\n[[:space:]]+{\n[[:space:]]+"identifier": ")[^"]*("\n[[:space:]]+}\n[[:space:]]+\]\n+[[:space:]]+})/m';
$str = '{"parameters": [
{
"name": "dir_parm",
"value": "changethis"
}
],
"targets": [
{
"identifier": "hsotchangethis"
}
]
}';
$subst = "$1>>>>>$2>>>>>>>$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;