re = /^(.*?)\s*(\d+)\.(\d+)$/m
str = 'Hebrews 11.6
2 Chronicles 10.16
Romans 13.13
2 Kings 5.10
3 John 1.5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end