package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^methods/[^/\n]+$`)
var str = `methods/english/dummy
methods/english
methods/french
methods
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}